Problem beim Rating >>> $repeat(*,%rating%)$repeat( ,$sub(5,%rating%))

Begonnen von Souldancer, 17. Januar 2009, 22:02:09

« vorheriges - nächstes »

Souldancer

Hallo,
habe den folgenden string im Default Ui  eingefügt.

$repeat(*,%rating%)$repeat( ,$sub(5,%rating%))

Wenn ich jetzt einen Titel über die rating funktion bewerte bekomme ich in der Playlist die richtige Anzahl der Sterne angezeigt z.B.4 Stück aber in den Selection Properties/Metadat/Other zeigt er immer 5 Sterne davon ist einer nicht ausgefüllt; also auch 4.
Aber wieso ist die Anzeige unterschiedlich die Schriftart ist für beide Felder die gleiche (Tahoma).  :o

Gibt es da eine Abhilfe?

Gruß

Olli

tedgo

Es ist völlig egal, welche Zeichen du in der Rating-Column in der Default UI (oder auch in der Columns UI) angibst.
Im Properties-Fenster sind immer die ausgefüllten bzw. leeren Sterne zu sehen.
Es sei denn, du hättest eine Non-Unicode-Schriftart, dann hättest du 5 hübsche Kästchen ;).

Übrigens:
Dein String:
$repeat(*,%rating%)$repeat( ,$sub(5,%rating%))
füllt die fehlenden Serne mit Leerzeichen auf, das macht eigentlich keinen Sinn.
Ist das so gewollt?
Wenn du einfach nur 'Nichts' haben willst reicht:
$repeat(*,%rating%)

Souldancer

Hallo,
habe den String mal geändert............kann aber keinen Unterschied feststellen..............
vielleicht verstehe ich den Unterschied auch nicht. Aber die Anzeige in der Playlist hat sich nicht verändert!

Olli

tedgo

Natürlich hat sich nichts geändert.
Du hast nur den überflüssigen Teil mit den Leerzeichen am Ende herausgenommen.

Was ist jetzt eigentlich das Problem?
Das du in der Playlist auch Sterne wie in den Properties haben willst?
Dann must du für die Rating Column in deiner Playlist das eingeben:
$repeat($char(9733),%rating%)$repeat($char(9734),$sub(5,%rating%))