DarkOne4Mod: modernisierte Config für CUI

Begonnen von tedgo, 29. September 2016, 13:43:17

« vorheriges - nächstes »

grimes

10. Oktober 2019, 09:47:34 #180 Letzte Änderung: 10. Oktober 2019, 09:52:07 von grimes
Das Rating ist zu dunkel.

Greenshot_2019-10-10_09-40-55.png

max

erster fehler beim umschalten der Button

grimes

View 3, mit den Cover Kacheln. No Cover Bild wird nicht angezeigt.

Greenshot_2019-10-10_10-09-31.png

max

bei mir so weit alles in ordnung

grimes

(Da ist bei dir aber kein No-Cover Bild dabei.)

View 2. Es wird ein anderes No Cover Bild angezeigt.

Greenshot_2019-10-10_10-25-11.png

tedgo

10. Oktober 2019, 10:38:12 #185 Letzte Änderung: 10. Oktober 2019, 15:29:55 von tedgo
@max
Wegen dem Frame: sollte mit der angehängten Datei behoben sein.

Wegen Button-Crash: Kann den angegebenen Fehler nicht nachvollziehen...
Habe aber jetzt mal was probiert...

Bitte kopiere die entpackten Dateien aus dem Anhang nach cui-configs/darkone4mod/jscript/js

@grimes
Bewertest du in die File Tags oder die Datenbank?
Ich vermute mal die File Tags.
Ich habe Datenbank- und Tagbewertung nun strikt getrennt.
Standardmäßig wird nur das Rating in der Datenbank angezeigt.
Möchtest du etwas anderes angezeigt haben musst du folgendes machen
* ELPlaylist: Settings --> Field Definition --> RATE.MODE von 0 auf 1 stellen, wenn du die Bewertungen in den Tags angezeigt haben willst, oder auf 2 stellen (alte Darstellung: wenn Bewertung in Tags vorliegt, wird diese angezeigt, sonst die Datenbank, sonst nix)

* NGPlaylist: Preferences --> Columns UI --> Playlist view --> Columns --> Rating
ebenfalls in $puts(rate.mode,0) auf 1 oder 2 stellen.

* Rating Panel: Rechtsklick und gewünschten Modus einstellen.

Ich dachte, die strikte Trennung ist besser als die vorige Vorgehensweise, da es u. U. zu Anzeigefehlern kam.
-----
Das No Cover Bild für NG Playlist und EsPlaylist musst du als "Stub image path" in Preferences --> Display angeben, da ich in diesen Playlists kein Bild einkodieren kann...
Das Bild liegt im Ordner: cui-configs/darkone4mod/images/albumart/Front cover.png

EDIT:
Obsoleter Anhang entfernt
Neuer Anhang HIER

grimes

10. Oktober 2019, 10:45:11 #186 Letzte Änderung: 10. Oktober 2019, 10:49:47 von grimes
Ich habe die Ratings sowohl in der Datenbank als auch im tag im file.
Das Problem ist aber nicht, dass die ratings nicht angezeigt werden, sondern dass die Farbe der Sterne zu dunkel ist (Schwarze Sterne auf schwarzen Hintergrund)

EDIT: Stub image eingetragen, nun ist alles ok.

tedgo

10. Oktober 2019, 10:56:29 #187 Letzte Änderung: 10. Oktober 2019, 11:00:44 von tedgo
Die Sterne sind nicht schwarz... sollten weiß sein!
Und bei mir sind sie das auch...

Im Rating Panel sind sie auch schwarz?

P.S: Ach...
Du hast ja eine portable Installation und da natürlich die Datenbank nicht mitgenommen... deshalb zeigt es bei dir keine Sterne an, da die Anzeige jeweils auf die Anzeige der Ratings in der Datenbank eingestellt ist. Du musst also wie oben beschrieben auf den RATE.MODE 1 oder 2 umstellen ;)


@max
Hab den Fehler im Button-Code gefunden (ein Rundungsfehler, der dazu führt, dass sich die abgerundeten Ecken gegenseitig bei den schmalen Buttons überschneiden würden. Deshalb der Crash).
Wird behoben.
Danke für den Hinweis! :)

grimes

10. Oktober 2019, 11:06:58 #188 Letzte Änderung: 10. Oktober 2019, 11:14:51 von grimes
Rechts oben die Sterne sind überhaupt nicht zu sehen. Was mache ich falsch?

Seltener Crash bei VUMeterStyle Style 1 bis 6:

Greenshot_2019-10-10_11-05-00.png

Kann nur selten reproduziert werden.

EDIT:
ZitatDu musst also wie oben beschrieben auf den RATE.MODE 1 oder 2 umstellen
Funktioniert.

tedgo

10. Oktober 2019, 11:37:37 #189 Letzte Änderung: 10. Oktober 2019, 12:09:41 von tedgo
@grimes
Hast du Zwischendurch den VU Meter übers Kontextmenü des VU Meters umgestellt?
Ich versuche gerade herauszufinden woran das liegt...
Hatte den Fehler nämlich auch schon mal...

Lösche am Besten im Ordner cui-configs/darkone4mod/settings die DO4M_VU_BACK_* Datei(en).
Und starte dann foobar2000 neu.
Hat bei mir damals geholfen und den Fehler konnte ich seitdem nicht mehr reproduzieren.

Ich frag ja auch extra ab, ob die Datei schon existiert.

P.S.
Hast du mal in den Ordner geschaut?
Sind da möglicherweise zwei DO4M_VU_BACK-Dateien drin?

grimes

Diese Dateien existierten, hatten allerdings eine Größe von 0 Bytes

tedgo

Ja, sollen ja auch leer sein.
Die werden nur erstellt, um deren Namen im PSS als globale Variable zu laden (und so das passende Hintergrundbild für den VU Meter zu laden).

Allerdings soll nur eine Datei vorhanden sein.
Wie eine zweite entstehen kann, kann ich mir im Moment nicht erklären...

tedgo

10. Oktober 2019, 12:15:15 #192 Letzte Änderung: 10. Oktober 2019, 15:30:12 von tedgo
So, im Anhang mal der korrigierte Textbutton und das korrigierte Display panel.
Wie gehabt die entpackten Dateien in den Ordner cui-configs/darkone4mod/jscript/js kopieren.

Der Crash im Button-Panel sollte dann behoben sein.

EDIT:
Habe nun im Display Panel etwas umgestellt.
Der Crash beim Umschalten der VU Meter übers Display könnte damit behoben sein...
Bitte probiert das mal aus.

EDIT2:
Obsoleter Anhang entfernt.
Aktualisierte Scripts HIER

max

So noch mal alles probiert es geht.
mit dem Cover glaube ich liegt das am getagten Cover Bild selbst unterschiedliche Größen.

tedgo

Das habe ich mir fast gedacht... ;)

Das Workaround war jetzt auch nicht optimal, weil ich einfach window.Repaint() ausführe, statt window.RepaintRect() mit den Koordinaten des Frames. Was aber das ganze Panel neuzeichnet.
In DarkOne4 ist das zwar kein Problem, weil Panel und Frame bis auf Rundungsfehler beim Resizen die gleiche Größe haben, aber wenn man das Cover einmal in eine andere Config einbauen möchte und da in das gleiche Panel noch andere Scriptteile zeichnet, refreshen die jedes mal mit.

Dann mach ich das wieder rückgängig.