DarkOne4Mod: modernisierte Config für CUI

Begonnen von tedgo, 29. September 2016, 13:43:17

« vorheriges - nächstes »

tedgo

@max

Das kommt von der Interpolation, damit die Schrift sauberer aussieht.
Ist also völlig normal.

@fbfrosch und alle anderen
Habe die Beta2 hochgeladen: KLICK MICH
Darin die bisherigen Fixes und eine kleine Änderung der dynamischen Koordinaten der Playlist (gab einen kleinen Mangel beim Resizen, der durch Rundungsfehler entstand).
Auch ein kleiner Mangel im Code der ELplaylist wurde noch behoben.

Bitte in eine frische foobar2000-Portable installieren!
Nicht, dass mögliche Überbleibsel der Beta1 "dazwischenfunken".

Danke fürs Testen
tedgo aka Gerhard

tedgo

Bug entdeckt!

Die "Now"-Schaltfläche rechts unterhalb der Playlists ist ohne Funktion, da es den verwendeten Befehl nicht mehr gibt.

Bitte auf die Schaltfläche rechtsklicken --> Splitter Settings --> Registerkarte "Script/PerTrack".
Da ganz runterscrollen und den Bereich // ----- BUTTONS ----- hiermit ersetzen:

// ----- BUTTONS -----
$textbutton(0,0,0,0,,,,,)
$textbutton($sub($div(%do.panel.w%,16),$div($get(w1),2)),$get(y),$get(w1),$get(t.h),$getcaption(0),$getcaption(0),SETGLOBAL:do.playlist.switch:1;REFRESH,fontcolor:$ifequal(%do.playlist.switch%,1,%do.btn.xcol%,%do.btn.ncol%),fontcolor:$ifequal(%do.playlist.switch%,1,%do.btn.xcol%,%do.btn.hcol%))
$textbutton($sub($muldiv(%do.panel.w%,3,16),$div($get(w2),2)),$get(y),$get(w2),$get(t.h),$getcaption(1),$getcaption(1),SETGLOBAL:do.playlist.switch:2;REFRESH,fontcolor:$ifequal(%do.playlist.switch%,2,%do.btn.xcol%,%do.btn.ncol%),fontcolor:$ifequal(%do.playlist.switch%,2,%do.btn.xcol%,%do.btn.hcol%))
$textbutton($sub($muldiv(%do.panel.w%,5,16),$div($get(w3),2)),$get(y),$get(w3),$get(t.h),$getcaption(2),$getcaption(2),SETGLOBAL:do.playlist.switch:3;REFRESH,fontcolor:$ifequal(%do.playlist.switch%,3,%do.btn.xcol%,%do.btn.ncol%),fontcolor:$ifequal(%do.playlist.switch%,3,%do.btn.xcol%,%do.btn.hcol%))
$textbutton($sub(%ps_width%,$add($muldiv(%do.panel.w%,5,16),$div($get(w4),2))),$get(y),$get(w4),$get(t.h),Now,Now,COMMAND:View/Show now playing in playlist;REFRESH,fontcolor:%do.btn.ncol%,fontcolor:%do.btn.hcol%)
$textbutton($sub(%ps_width%,$add($muldiv(%do.panel.w%,3,16),$div($get(w5),2))),$get(y),$get(w5),$get(t.h),Find,Find,COMMAND:Edit/Search;REFRESH,fontcolor:%do.btn.ncol%,fontcolor:%do.btn.hcol%)
$textbutton($sub(%ps_width%,$add($div(%do.panel.w%,16),$div($get(w6),2))),$get(y),$get(w6),$get(t.h),Clear,Clear,COMMAND:Edit/Clear;REFRESH,fontcolor:%do.btn.ncol%,fontcolor:%do.btn.hcol%)

grimes

Hab ich gemacht. Nun ist die "Clear" Schaltfläche nicht mehr da.

tedgo

13. Oktober 2019, 09:50:43 #213 Letzte Änderung: 13. Oktober 2019, 09:53:29 von tedgo
Dann schau mal, ob du nicht versehentlich eine Klammer am Ende der letzten Zeile oder die letzte Zeile beim Auswählen übersehen hast.

Wähle den Code am Besten mit der Schaltfläche "Auswählen" --> Strg+C aus.
Bei mir klappt es jedenfalls, hab es gerade probiert.

grimes

ahh, hab die syntax nicht vollständig kopiert. Danke.

tedgo

Beta 3 hochgeladen: Klick mich, wenn du dich traust

Fix: nicht arbeitende "Now"-Schaltfläche
FIX: vergessene Farb-Optionen im Lautstärkeregler ausgebessert
FIX: verwirrende "VU Meter Style"-Auswahl bei eingeschaltetem Channel Spectrum Panel abgeschaltet

Bitte wieder in einer frischen portablen foobar2000-Installation testen!

Danke :)
tedgo aka Gerhard

P.S.: ich hoffe, das ist die letzte Beta.
Wenn alles tadellos und ohne Verwirrungen funktioniert, portiere ich dann das Ganze als DarkOne4 v2.0 CLX (dauert etwa eine Woche) und schreibe das Manual.pdf (da gebe ich mir noch eine Woche... wenn ich die Lust dazu finde...). Danach wird veröffentlicht.

max

20. Oktober 2019, 09:10:21 #216 Letzte Änderung: 20. Oktober 2019, 09:12:28 von max
hallo tedgo
läuft so weit alles sehr gut.
gruß max :top:

max

Habe fest gestählt das die Lautsprecher regelung bei -100% bis zu Position -30% das der weg sehr lange ist.
ist aber natürlich nur beim scrollen so.

tedgo

Beim Scrollen wird die Lautstärke in 1dB-Schritten geändert.
Und von -100dB bis -30dB sind es halt nun mal 70 Schritte ;-)
Dass der Indikator sich in dem Bereich aber nur wenig bewegt, liegt an der logarithmischen Darstellung, die dem Lautstärkeempfinden des Gehörs näher kommt als die lineare Darstellung.
Das werde ich also wahescheinlich nicht ändern.
Was ich machen könnte, wäre im Bereich unterhalb -15dB die Schritte zu erhöhen (das insgesamt z. B. nur 30 oder 50 Schritte "gescrollt" werden).
Aber ich halte die 1dB-Lösung eigentlich für "feinfühliger".

max

ok
es läuft so weit alles sehr gut noch mal echt tolle arbeit von dir.

tedgo

Na, das klingt doch schon mal gut :)

Ein Betatester hat allerdings ein Problem, dass ich nicht nachvollziehen kann:
Beim schnellen Umschalten von Radiostream (mp3) auf ein Flac-File würde das Display crashen, wenn es auf Dot Matrix gestellt ist.
Die Crashmeldung meldet einen Overflow in der Erstellung des Bitmaps, das die Bitrate darstellt.

Ich habe das auf meinem Uralt-System jetzt mit verschiedenen Flac-Files und Radiosendern ausprobiert, bekomme diesen Fehler aber einfach nicht hin...

Probiert ihr das mal aus?

Irgendwas muss wohl mit der Bitrate des Streams oder des Flac-Files des Betatesters seltsam sein... jedenfalls wäre es gut zu wissen, wie das zustande kommt. Dann kann ich einen möglichen Crash "abfangen".

max


tedgo

Nein, damit hat das wohl nichts zu tun.
Es muss etwas mit der Bitrate des Streams oder des Flac-Files zu tun haben.
Kann es sein, dass da in speziellen Fällen mal was anderes ausgegeben wird, als eine Zahl?
(Aber wie soll das gehen?)

grimes

Der Bug tritt bei mir auch nicht auf. Stream: BR Klassik.
Was mir ansonsten aufgefallen ist, dass die Sterne bei Radio Streams wieder schwarz sind.

tedgo

Ja, bei Streams habe ich die Ratingmöglichkeiten und deren Anzeige abgeschaltet.
Oder bewertet da jemand Radiostreams?