ID3v2-Tags - Version beeinflussen und Frage zu ID3-v1-Tags

Begonnen von MrMurphy, 12. Dezember 2020, 02:26:36

« vorheriges - nächstes »

MrMurphy

12. Dezember 2020, 02:26:36 Letzte Änderung: 12. Dezember 2020, 02:48:59 von MrMurphy
Ich beschäftige mich grade bei foobar2000 V. 1.6.2 portable unter Windows 7 mit den ID3-Tags.

Ich lasse die ID3-Tags durch foobar2000 über "Automatically fill values..." in die MP3-Dateien schreiben. Das funktioniert auch grundsätzlich.

Ich würde gerne nur folgendes ändern: foobar2000 schreibt die ID3-Tags in Version 2.4, die wohl als unsicher gilt. Deshalb sollen die ID3-Tags besser in der Version 2.3 geschrieben werden. Kann ich das beeinflussen und falls ja, wie?

Unter "File - Preferences - Advanced - Tagging - MP3 - ID3v2 revision and quirks" ist "Write ID3v2.3 tags (more compatible)" ausgewählt. Demnach empfehlen die Autoren von foobar2000 in der aktuellen Version auch die ID3-Version 2.3.

Unter "File - Preferences - Advanced - Tagging - MP3 - Tag writing scheme for untagged files" ist "ID3v2 + ID3v1" eingestellt. Eine genauere Eingrenzung ist offensichtlich nicht vorgesehen. Oder übersehe ich etwas, kann eventuell an anderer Stelle die Version geändert werden?

Bei den ID3-v1-Tags werden Titel, Interpret, Album und Kommentar eingetragen. Was muss ich ändern damit auch das Jahr übernommen wird? Dafür sind meiner Kenntnis nach 4 Zeichen vorgesehen. Muss eventuell eine Bezeichnung unter "File - Preferences - Advanced - Display - Properties dialog - Standard fields" geändert werden? Aktuell steht dort bei mir

DN=disknumber;TN=tracknumber;TrackTitle=title;TrackArtist=artist;TrackAuthor=trackauthor;AlbumTitle=album;AlbumArtist=albumartist;AlbumDate=albumdate;TrackDate=trackdate;Author=author;Genre=genre;Sprache=language;Comment=comment;


MrMurphy

Zu den ID3v1-Tags habe ich eine Lösung gefunden. Die Übernahme hängt wohl von der richtigen Bezeichnung der "Standard fields" ab. Nach ich "TrackDate=trackdate" in "TrackDate=date" geändert habe funktioniert die Übernahme.

Um ID3v1-Tags vollständig zu schreiben müssen damit wohl die Felder title, artist, album, comment und date in den "Standard fields" vorhanden sein.

grimes

Unter standard fields steht bei mir:
Artist Name=ARTIST;Track Title=TITLE;Album Title=ALBUM;Date=DATE;Genre=GENRE;Composer/Members=COMPOSER;Composer/Band=PERFORMER;Album Artist=ALBUM ARTIST;Track Number=TRACKNUMBER;Total Tracks=TOTALTRACKS;Disc Number=DISCNUMBER;Total Discs=TOTALDISCS;Comment=COMMENT;